Taak: Eén resultaat berekenen

In dit onderdeel wordt uitgelegd hoe je één matrixformule kunt gebruiken in situaties waar je anders meerdere formules voor nodig hebt.

Je kunt een matrixformule gebruiken wanneer je diverse berekeningen moet uitvoeren om één resultaat te krijgen. Dit type matrixformule kan een werkblad vereenvoudigen doordat meerdere formules worden vervangen door één matrixformule.

In het volgende voorbeeld is een aandelenportefeuille met koersen te zien. Om nu de totale waarde van de aandelen bij een bepaalde koers te berekenen zou je normaliter voor elk aandeel de waarde moeten berekenen en dan deze waardes optellen. Met een matrixformule kan dit resultaat in één keer berekend worden.

Figuur 1. Koersen van aandelen
Koersen van aandelen
Bestand: Matrix3.xlsx
  1. Open het hulpbestand.
  2. Selecteer cel C6.
  3. Voer de volgende formule in =SOM(B2:B5*C2:C5).
  4. Herhaal de actie voor cel D6, de formule wordt nu =SOM(B2:B5*D2:D5).
    Tip: Door in de formule in C6 de eerste kolom van de matrix absoluut te maken, dus =SOM($B$2:$B$5*C2:C5), kun je de formule naar D6 kopiëren.

Voorbeeld: gemiddeld cijfer

In dit voorbeeld wordt van leerlingen het gewogen gemiddelde van vier toetsen met een matrixformule berekend. De formule is geschikt om gekopieerd te worden. Maak dit voorbeeld na.

Figuur 2. Gewogen gemiddeldes
Gewogen gemiddeldes
Bestand: Matrix4.xlsx